Translate
Sub Menu
Links Menu
Online Users

In total there are 72 users online :: 2 registered, 0 hidden and 70 guests

Most users ever online was 372 on Thu May 09, 2019 3:50 am

Registered users: Bing [Bot], Majestic-12 [Bot] based on users active over the past 60 minutes

Last Online
In order to view the online list you have to be registered and logged in.



We are a free and open
community, all are welcome.

Click here to Register

Disappointments....

Any feedback, suggestion and comments relating to the IntegraMOD project can be posted here. NO bug reports should be posted in this forum

Moderator: Integra Moderator

Disappointments....

PostAuthor: alumsprings » Sun Aug 05, 2007 9:30 pm

I have very little knowledge of php, so when I get screens full of what looks a lot like a bunch of code I have no idea where to begin to look for problems. Sometimes you get error messages telling you about files and that does give you a starting point. However, sometimes an error message may point to the wrong file.

At any rate, I love Integramod and have used it for all my sites for about the past 3 years. But the most recent release was something of a disappointment to me. Oh, it has great features, but the coding of the current download is pretty sloppy.

For one thing, the news_data.php file needs to be replaced. I wasn't the only one that had isssues with that file. Apparently, and I don't know why, but in the latest download of 1.4.1, there is a line missing that is necessary so that expanding the news block will work properly.

Another issue I had with this particular version is the php coding itself. On some servers, for reasons I do not know, it's a snap setting up. But some hosts are a little more finicky than others and little things such as <? or <?PHP instead of <?php make a big difference.

It's been a real pain in the bum setting up this latest site primarily because of the <? or <?PHP issue. Personally, I don't have time to go through 3,000 individual files changing it. So I went back to an older version that has never given me problems before.

Anyway, I still love Integramod....But I reckon I'm going to have to just stick with the older generation.
Last edited by alumsprings on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.

alumsprings
Members
Members
 
Posts: 34
Joined: Sat May 05, 2007 6:13 pm

PostAuthor: tmotley » Mon Aug 06, 2007 4:32 am

I downloaded my 1.41 many moons ago and it functioned wonderfully pretty much out of the box. Yes, cracker tracker was irritating at first but I did not have all of the glitches you encountered.

I'd bet there were multiple corrupted files in your setup... corrupted on the uploading process perhaps. They certainly aren't corrupt from IM since there aren't more occurrences of your 'issues.'

That being said, I'm glad you've chosen to stick with IM, albeit an older version, and don't hesitate to continue to request support.
Last edited by tmotley on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
User avatar
tmotley
IntegraMODerators
IntegraMODerators
 
Posts: 524
Joined: Mon Mar 27, 2006 3:56 am
Location: Missouri, USA

PostAuthor: alumsprings » Mon Aug 06, 2007 7:54 pm

No, there weren't "multiple corrupted files" in my setup. I have set up Integramod for at least 6 sites and never had problems before like I have had this time.

There *IS* a problem with news_data.php in the download that is available here for download. I can believe that maybe it got corrupted once in the download or upload....But I downloaded the file from here twice....I uploaded and installed it twice....with the very same exact problems both times.....And that very same file was messed up EXACTLY in the same place for another person....who DIDN'T get his/her download from me.....So you would definitely lose that bet....It needs to be corrected.

And the only "multiple corruption" there was in my files were multiple files that began with <? or <?PHP and after talking with my host and you as well on one of the files I spoke about here incidentally, that putting it there as <?php would correct the problem.

It is just extremely strange to me that the only corruption that occurred to the files I downloaded was a few files lost the "php" at the end of the very first line.
Last edited by alumsprings on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.

alumsprings
Members
Members
 
Posts: 34
Joined: Sat May 05, 2007 6:13 pm

Re: Disappointments....

PostAuthor: tmotley » Mon Aug 06, 2007 8:55 pm

I apologize for offending you...

I redownloaded the 141 package that was made available in January of this year. I will confirm that news_data.php and news_common.php do not have the php at the beginning like they should... at least according to me Crimson Editor. Those were the only ones I checked.

news.php's readmore link doesn't seem to function correctly either. My 'fixing' of this is in the following topic: http://www.integramod.com/forum/viewtopic.php?t=3996

More than 1 of your files were 'corrupt,' no?
I said 'perhaps' meaning possibly but not positively.
Most IMers are not having the number of issues you encountered so there must be something else happening, PERHAPS host-related?

Good luck in the future...
Last edited by tmotley on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
User avatar
tmotley
IntegraMODerators
IntegraMODerators
 
Posts: 524
Joined: Mon Mar 27, 2006 3:56 am
Location: Missouri, USA

Re: Disappointments....

PostAuthor: Helter » Mon Aug 06, 2007 11:10 pm

it appears the dl has become corrupted somehow. i just checked it out and news.php is fine, however news_common was missint the php open/close tags. This is not the case in the file that the dl was made from and since 12000 others are running 141 without this problem, Im assuming it was a recent development.
The programing had nothing to do with it, but if you feel better by calling it sloppy, then so be it, but part of the concept of community software development is constructive critisism and community effort...
Last edited by Helter on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
Image
Please do not PM for support
User avatar
Helter
Administrator
Administrator
 
Posts: 4125
Joined: Sat Mar 11, 2006 4:46 pm
Location: Seattle Wa

Re: Disappointments....

PostAuthor: alumsprings » Tue Aug 07, 2007 8:46 am

I am not trying to piss anyone off here or offend....I am just telling you the issues I had with it and if I had problems with it, then it's just possible someone else might and it's honestly a pretty easy fix.....I guess sloppy is some what harsh....maybe careless would be better....I am basing my statement on that by information I got from my host.....

>I have a free host that I use every now and then for sites. When I run
> php software with that host, there are no problems. But when I put it
> on your servers, if in the file it isn't written as <php> beginning it causes all sorts of problems, but with this other host, it
> works anyway? I mean some of the files begin with <? or <PHP> still works....but on yours it doesn't. Why is that??
>
>

That is because your other host isn't as secure as we are. We put a very
big emphasis on using the updated PHP standards for all our clients. I do
appologize for that but by requiring all clients use updated standard PHP
code it makes for a much more secure and reliable hosting experience.

The free company doesn't want to bother with helping people who aren't using
updated PHP standards when writing their code so they leave all the legacy
tags in tact. <? was dropped from PHP standards a few years ago... It only
requires a simple search and replace on older PHP code to make it work with
the latest standards...

If you are looking for a good CMS that I can guarantee will remain updated
and fully supported by our server it is SiteX (sitex.bjsintay.com) it powers
PhiBetaLambda.org and CarolinaGamesSummit.com both of my most popular
websites. It is free and written by my admin, so it is developed on our
server and works 100% guaranteed...

He has been developing it for years and I have been using it from the very
beginning.


so there you have....and I stand corrected on the correct name of the file....But I had to edit so many just to get it to work on my site, I lost track....

And you're all missing the point here....I still think IntegraMod is the greatest thing since sliced bread....It's what I WANT to use....It's just annoying to have to go through every single file to make sure the it begins with <?php...

Obviously I'm the only one using it with a picky host, but if he is correct in what he said to me in that email, and I honestly believe he is, then you're going to see more feedback like this as time goes on....

One more thing, when you set up a feedback forum, it's not all going to be good.
Last edited by alumsprings on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.

alumsprings
Members
Members
 
Posts: 34
Joined: Sat May 05, 2007 6:13 pm

Re: Disappointments....

PostAuthor: Helter » Tue Aug 07, 2007 6:23 pm

what im saying is that every php file begins with <php>

I have checked the .svn export folder and gone through nearly 100 files to verify this.

I would normally believe that the problems in the IM140.zip were introduced during the zip compression process, however since this appears to be a new development and the file is several months old, I was stating that the file must have become corrupt. I dont pretend to understand how this could happen, because all other zip file corruption problems ive run into have resulted in a file that would not unzip. None have resulted in a file that unzips with partial, or incomplete files. There are several other ppl with the ability to edit the file and perhaps one of them did an update, but ive found no evidence of this. So do you understand the mystery? If this were a coding error, then the bad code would exist in the parent file and the svn file, but they do not.
Last edited by Helter on Thu Aug 09, 2007 8:34 am, edited 1 time in total.
Image
Please do not PM for support
User avatar
Helter
Administrator
Administrator
 
Posts: 4125
Joined: Sat Mar 11, 2006 4:46 pm
Location: Seattle Wa

PostAuthor: Whisky » Thu Aug 09, 2007 7:52 am

Helter you're drunk <img>
Last edited by Whisky on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
I am the Lizard King, I can do anything

Whisky
Sr Integra Member
Sr Integra Member
 
Posts: 256
Joined: Thu May 18, 2006 2:28 am
Location: Brussels

Re: Disappointments....

PostAuthor: Helter » Thu Aug 09, 2007 8:32 am

lol...it was so profound i thought Id post it twice... <img>
Last edited by Helter on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
Image
Please do not PM for support
User avatar
Helter
Administrator
Administrator
 
Posts: 4125
Joined: Sat Mar 11, 2006 4:46 pm
Location: Seattle Wa

Re: Disappointments....

PostAuthor: Teelk » Thu Sep 06, 2007 12:55 am

I don't mean to drag up old posts, but I believe I can solve the mystery. The <? instead of <?php issue is a problem with the original MOD and has always been this way in previous versions of IM as well as 141. For some reason, possibly due to newer php engines, it has just recently become an issue, albeit a rare one. This bug was caught some time ago, which is why the SVN is without this mistake.

It can be found in four files, the two aforementioned news files and the following two pafiledb files.

pafiledb/modules/pa_post_comment.php
pafiledb/uploads/index.php

[url=http]Here is the link to the original thread.[/url]
Last edited by Teelk on Wed Dec 31, 1969 5:00 pm, edited 1 time in total.
User avatar
Teelk
Dev Team
Dev Team
 
Posts: 1309
Joined: Tue Mar 14, 2006 6:25 pm
Location: Canada


Return to IntegraMOD Feedback

Who is online

Registered users: Bing [Bot], Majestic-12 [Bot]

cron